The New Forum Software

Discussion in 'Forum Problem Reports' started by pete, Dec 21, 2016.

  1. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    Xenforo.

    OK, we've sunk a lot of money and time into this new forum software. I hope you enjoy it.

    If you have any problems, post here or send me a Private Message, or e-mail thesaxinfo-at-gmail.com.

    * I haven't finished making things look pretty. I wanted functional, first. I actually turned off some of the pretty.
    * I have added a couple things to the HELP menu, so check that, first.
    * Check your permissions, please. If you were able to do something on the forum yesterday (or earlier) and now can't, that's a permissions problem. Again, post here, send me a PM, or e-mail me.
    * Check your user title, if you have one. Some may not have transferred properly.
    * As mentioned in the HELP menu, if you use Adblock or Flashblock, you need to turn them off. These things interfere with some of the buttons (really). I guarantee that you won't see any Flash ads here.
     
    Tags:
    TrueTone and SuzyJo like this.
  2. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    I have noticed that my setting for viewing people's signatures was turned off. This isn't a default for new users, so it might just be me or folks that were migrated to the new forum software. Anyhow, go to http://www.woodwindforum.com/testforum/index.php?account/preferences and put a checkmark next to "Show people's signatures with their messages" and hit the "Save Changes" button.
     
  3. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    1. I added back the forum "header" pictures ("node glyphs") in the default theme.
    2. I re-installed the Graphite base theme. After you login, you can change the Style by clicking on the extreme lower left corner of the screen (which should say "Elegance 2 (Blue - Default)") or going to the direct link. Note that some of the changes that I do to the default theme will NOT be available in any other theme.
    3. I noticed that the forum profile posts were, in some users' cases, quintuplicated. I think I've now deleted all the extra copies. Don't know what a profile post is? Click on your avatar icon or go to the direct link.
     
  4. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    4. I made a small tweak to the sidebar on the main page so you can now see the latest profile posts and some other stats.
    5. I made a bigger tweak to the Graphite - Base theme to include the HELP and ALBUMS menu items when you hover your cursor over FORUMS (upper left corner of the screen).
     
  5. saxhound

    saxhound Moderator Staff Member CE/Moderator

    Joined:
    Feb 1, 2008
    Messages:
    449
    Likes Received:
    67
    Looks great Pete. Thanks for all your hard work.
     
  6. Gandalfe

    Gandalfe Administrator Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    5,535
    Likes Received:
    141
    Interesting. Before I log in, I can read topics and posts, but the signatures are not present. When I log in, the signatures appear.
     
  7. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    You're welcome.

    Makes me think even more that it's an SQL table that didn't get filled. I'll try to check into that a bit more tomorrow, but I haven't decided if I want to make the food for Christmas on the 25th or 24th -- I'm making spaghetti and that can be chilled for about a week.
     
  8. saxhound

    saxhound Moderator Staff Member CE/Moderator

    Joined:
    Feb 1, 2008
    Messages:
    449
    Likes Received:
    67
    Family first. Forum later. Happy Holidays to all.
     
    TrueTone and Gandalfe like this.
  9. Gandalfe

    Gandalfe Administrator Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    5,535
    Likes Received:
    141
    Correcto mundo. Family comes first for me too. Happy holidaze all!
     
    Last edited by a moderator: Dec 24, 2016
  10. SuzyJo

    SuzyJo Gandalfe's Wife

    Joined:
    Dec 26, 2007
    Messages:
    23
    Likes Received:
    0
    Thanks Pete.
     
  11. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    You're very welcome, folks.

    I'll do the cooking tomorrow, so it'll be extra fresh.
     
  12. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    I've finished installing and modifying probably my favorite Style, Graphite (Gray). I just reused the node (category) icons from the Elegance 2 Base theme, so RSVP if the colors look a bit wacky.
     
  13. saxhound

    saxhound Moderator Staff Member CE/Moderator

    Joined:
    Feb 1, 2008
    Messages:
    449
    Likes Received:
    67
    Looks good, but I like the Elegance just fine. White text on the dark background makes my eyes go bonkers after a while.
     
  14. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    That got me to think, "Well, what if I can get just a black and white Style?" However, that'd still mean that the avatars would be in color. Well, how about making the screen go greyscale (like a black-and-white TV)? I can do that through my graphics card settings on my PC, but that's too bothersome. So, I Googled. Of course there's a free program to do that for you. It's called NegativeScreen. No installation required. Just download, unzip, double-click the one for your version of Windows, and press Win-Alt-F11. Press Win-Alt-H to get back to normal.

    I've got about 16 or so style packs for Graphite (dark) and Elegance 2 (light). There are only two caveats: lotsa Styles makes changing some things on the administrator end really slow, so I don't want to go too nuts, yet. Second, all those fun node ("category") icons need to be rebuilt for the right color scheme. That takes quite awhile.
     
    TrueTone likes this.
  15. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    BTW, if any of you see something that looks like :something: (note the colon at the beginning and end), it means I've missed a smilie code. Please post here with the code ( i.e. :something: ) and I'll fix it.

    I've uploaded 1300 smilies for this new forum. We're slowly adding them.
     
    Gandalfe and TrueTone like this.
  16. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    Elegance 2 (Green) theme uploaded. IIRC, this one was Gandalfe's favorite.
     
    Gandalfe likes this.
  17. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    I'm probably going to switch this forum to its permanent directory (i.e. the Xenforo recommended "community," "forum" rather than "testforum") on Monday, as I have the day off. That will then allow me to start fixing the various links we've had to places on the old forum. This will mean the forum will be offline at least for a little bit. I don't have an exact time, as I haven't done this in Xenforo before, and it's been a looooooooong time since I've done that in vBulletin.

    Oh. Helen's finished coding the smilies. When you post a message, click on the smilie face in the above toolbar and you'll get a bunch of choices.

    itd_3d_ani_w60_smiles_044.gif
     
    Last edited: Jan 2, 2017
  18. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    Oh. I also found the setting for this. It's now on for not-logged-on users.
     
    Gandalfe likes this.
  19. Gandalfe

    Gandalfe Administrator Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    5,535
    Likes Received:
    141
  20. pete

    pete Brassica Oleracea Staff Member Administrator

    Joined:
    Dec 26, 2007
    Messages:
    10,649
    Likes Received:
    377
    As you can probably see, I didn't move the forum to the "community" directory, but to the "forum" directory. The "community" directory was already in use, oddly enough, and when I tried to just do some renaming fun, the new forum wouldn't open any page. I considered moving to the "forums" directory, which is where we had the old vBulletin forum, but there's still a bunch of stuff that I have to get off the old forum, so I didn't want to kill that.

    Anyhow, I'm going to be fixing links, over the next few days. If you find a link that doesn't work, RSVP. Just copy and paste the URL of the page you went to that has the broken link, like http://www.woodwindforum.com/forum/index.php?threads/the-new-forum-software.25140.

    Thanks!
     

Share This Page

Our staff's websites:


Loading...